ASTRO Camp 1st Demo Day 活動筆記

比較知名雲端服務桌面同步軟體的錯誤訊息設計

因為有安裝雲端硬碟或雲端筆記等服務的同步軟體的需要,但是手邊這台電腦的作業系統太舊,導致多數廠商並不支援。從不同軟體 Google Drive, Microsoft OneNote, OneDrive, Apple iCloud, Amazon, Asus Webstorage, Evernote, Notion, Dropbox 的錯誤訊息來比較錯誤訊息設計。

Google Drive 顯示「沒有可用的更新」

狀況1: 蛤~不知道發生什麼事情

Microsoft 的 OneNote 下載連結上方有明顯地標示「支援 Windows 7 或更新版本以及 OS X Yosemite 10.10 或更新版本」 ,如果執意下載,就會遇到天書般錯誤訊息的懲罰。Microsoft OneDrive 或 Apple 的 iCloud for Windows 網頁下方有額外連結,另開一頁說明作業系統的最低條件,如果沒有注意而安裝,也會遇到神祕的錯誤訊息文字。
OneNote 顯示「無法找到程式輸入點 ... 在動態連結程式庫 ...」

OneDrive 顯示「不是正確的 Win32 應用程式」

iCloud 顯示「不是正確的 Win32 應用程式」
Google Drive 忙碌一陣子後,顯示「沒有可用的更新」,點選「說明」按鈕,才會清楚這位機器人嘗試要表達的是什麼。
Google Drive 顯示「沒有可用的更新」

狀況2: 說明要安裝 Microsoft .NET Framework

Amazon Drive apps 或 ASUS WebStorage 都顯示需要安裝 Microsoft .NET Framework,使用者要費心去網路上搜尋可以支援舊電腦的 NET Framework,後續狀況不明。

Amazon Drive apps 顯示需要安裝 .NET Framwwork v.4.x

ASUS WebStorage 顯示需要安裝 .NET Framwwork v.2.x

狀況3: 直接說明不支援舊的作業系統

Evernote 或 Notion 執行安裝檔案後,直接顯示不支援舊的作業系統版本。

Evernote 安裝的錯誤訊息

Notion 安裝的錯誤訊息

狀況4: 不支援的舊電腦,就不要下載同步軟體了

Dropbox 網頁上偵測到使用者用的是不支援的舊電腦,就不提供同步軟體下載
Dropbox 請你換電腦
如果是支援的作業系統版本,才自動下載 Dropbox 軟體
恭喜你,Dropbox 自動下載軟體中...

小結

儘管是非常明確的錯誤情況,但是從不同例子中遭遇的挫折感程度、錯誤訊息文字是否明確、使用者下一步驟要做什麼,可以從中比較不同家同步軟體的錯誤訊息設計優劣。

參考資料

Creating Error Messages | Best practice in UX Design



留言